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WHAM Keys
Use the following keys in Waveform Hold and Modify;
Press                   To                   Left Arrow          Move the cursor   left by one screen position; that 

is, by a number of samples equal to the scale.
Right Arrow Move the cursor right by one screen position.
Page Up Moves the cursor left by the width of the window.
Page Down Moves the cursor right by the width of the window.
Home Move the cursor to the start of the sound.
End Move the cursor to the end of the sound.
P Play the entire sound.
Ctrl+P Play the selected portion of the sound, or the current sound from the cursor.
Shift+Del Cut the sound, or a selected portion of it, to the clipboard.
Ctrl+Ins Store a copy of the sound, or of a selected portion of it, in the clipboard.
Shift+Ins Paste the contents of the clipboard into the current sound.
Del Delete a selected portion of the current sound.
Ctrl+N Zoom in on the selected portion of the current sound.
Ctrl+O Zoom out to view the current sound in its entirety.
Alt+F4 Exit from WHAM.



File Menu Commands
File|Record new
Opens the recording dialog, allowing you to record a sound through a sound card.

See Also
Recording a sound

File|Open
Opens an existing sound file. 

See Also
Loading a Sound from Disk
Sound File Formats

File|Save
Saves the current sound file to disk.

See Also
Saving a Sound to Disk
Sound File Formats

File|Save As
Saves the current sound file to disk under a different name.

See Also
Saving a Sound to Disk
Sound File Formats

File|Information
Allows you to view and change information about the current sound, such as the title and 
copyright information.

See Also
File Information Dialog

File|System information
Displays information about your hardware; this includes sampling/playback rates and 
maximum resolutions

File|Exit
Exits from Waveform Hold and Modify.



Edit Menu Commands
Edit|Cut
Puts the selected part of the current sound into the Clipboard and removes it from the 
sound. Any previous Clipboard contents will be replaced.
If nothing is selected, the entire sound will be cut into the Clipboard.

See Also
Copying Sound to the Clipboard
Selecting Part of a Sound

Edit|Copy
Places a copy of the selected part of the current sound into the Clipboard. Any previous 
Clipboard contents will be replaced.
If nothing is selected, the entire sound will be copied into the Clipboard.

See Also
Copying Sound to the Clipboard
Selecting Part of a Sound

Edit|Paste
Inserts sound from the Clipboard into the current sound. The new sound can be inserted at 
the start of the current sound, appended to the end, inserted at a selected point or be made 
to replace the current sound.

See Also
Inserting Sound from the Clipboard

Edit|Clear

Clears the selected part of the current sound, replacing it with silence. If nothing is selected, 
the entire sound is cleared.

See Also
Clearing Part of a Sound

Edit|Delete
Removes the selected part of the current sound. If nothing is selected, the entire sound will 
be deleted.

See Also
Deleting Part of a Sound

Edit|Delete unselected
Removes all but the selected part of the current sound.

See Also
Deleting Part of a Sound
Selecting Part of a Sound

Edit|Copy to file
Saves the selected part of the current sound to disk.

See Also



Saving Part of a Sound to Disk
Selecting Part of a Sound



View Menu Commands
View|Actual size

Displays the waveform at actual size. Each line on the display represents one sample.

View|1:2 scale

Displays the waveform at a 1:2 scale. Each line on the display represents two samples.

View|1:5 scale

Displays the waveform at a 1:5 scale. Each line on the display represents five samples.

View|1:10 scale

Displays the waveform at a 1:10 scale. Each line on the display represents ten samples.

View|1:100 scale

Displays the waveform at a 1:100 scale. Each line on the display represents 100 samples.

View|Zoom in

Displays the waveform at the smallest scale at which the entire selection is visible.

View|Entire sound

Zooms out to display the entire sound.

View|Full height

Displays the waveform at full height, adjusting the WHAM window's height.

View|Half height

Displays the waveform at half height, adjusting the WHAM window's height. Use this to 
conserve screen space.

View|Solid display

Displays the waveform in solid form.

View|Outline display

Displays the waveform as a line.

View|Blob display

Displays the waveform as a symmetrical blob.

View|Point display

Displays the waveform as a series of scattered points.





Effects Menu Commands
Effects|Change sign

Changes the sign of the current sound. This command allows signed sounds, such as Amiga 
sounds, to be converted to the Windows format.

See Also
Converting Amiga Sounds

Effects|Decode Mu-Law data

Converts the current sound from mu-law samples to linear samples. Be careful, because if 
the sound is not in mu-law format, this function will really make a mess of it.

Effects|Expand to 16 bits

Expands the current sound's resolution to 16 bits. This function is enabled only when the 
current sound has an eight-bit resolution.

Effects|Reduce to 8 bits

Reduces the current sound's resolution to eight bits. This function is enabled only when the 
current sound has a sixteen-bit resolution.

Effects|Reverse

Reverses the selected part of the current sound, causing it to play backwards.
If nothing is selected, the entire sound is reversed.

See Also
Reversing Part of a Sound

Effects|Volume|Increase (200%)

Increases the volume of the selected part of the current sound, making it twice as loud. If 
nothing is selected, the entire sound's volume is increased.

See Also
Changing the Volume of Part of a Sound

Effects|Volume|Decrease (50%)

Decreases the volume of the selected part of the current sound, making it half as loud. If 
nothing is selected, the entire sound's volume is decreased.

See Also
Changing the Volume of Part of a Sound

Effects|Volume|Change

Changes the volume of the selected part of the sound by a user-specified percentage. At 
present, the percentage is rounded to the nearest 50%.



See Also
Changing the Volume of Part of a Sound
Effects|Playback rate

Changes the playback rate of the current sound. The playback rate is specified in kilohertz 
(kHz). The higher the playback rate, the faster the sound is played.

See Also
Speeding Up or Slowing Down a Sound
Playback Rate Dialog

Effects|Stretch/Shrink

Physically changes the length of a sound. This allows a sound to be sped up or slowed down 
without changing its playback rate, or to be converted to a different playback rate.



Options Menu Commands
Options|Can modify unselected

If this menu item is checked then operations, such as copying and reversing, will be 
performed on the entire sound if nothing is selected. If this menu option is not checked, you 
have to select part of the sound before performing such an operation.

See Also
Selecting Part of a Sound

Options|Save settings on exit

If this menu item is checked, the dimensions of the WHAM window and the vertical scale will 
be saved when WHAM exits.

Note: If you wish to save the settings immediately, hold down Shift and select Exit from the 
File menu.

Options|Information defaults

Calls up a dialog that allows you to select whether WHAM reads the DOS creation date of 
files.

See Also
Information Defaults Dialog

Options|Format defaults

Brings up the Format defaults dialog , which allows you to set options specific to individual 
file formats.

Options|Window options

Calls up a dialog that allows you to specify how the WHAM window can be resized.

Options|Display options

Brings up the Display options dialog, which allows you to configure the way in which WHAM 
presents a sound on the screen.

See Also
Window Options Dialog



Recording a Sound
If you have a sound card that supports sound recording, you can use WHAM to record 
sounds.

To record a sound

1 From the File menu, select Record New.

Or press the Record button.

The recording dialog will appear.

2 Press the button marked Record in the dialog. The dialog should display the message 
"Allocating memory" above the buttons.
Please note that recording will not start immediately, as WHAM will attempt to allocate 
as much memory as it can.

3 When the line above the buttons reads "Recording commenced", WHAM will start 
recording sound. If you are recording through a tape or compact disc, press "Play" on 
the device; if you are recording through a microphone, speak (or sing, or yodel, or 
whatever    ) into the microphone.

4 When you have recorded what you wish to record, press the button marked Stop in the 
dialog. If WHAM runs out of memory before you do so, it will stop automatically.

5 To listen to your sound, press Play. If you like it, press OK. This will close the dialog and 
allow you to edit your sound in WHAM. If you do not like it, you may attempt to record it 
again, or you can discard it and close the dialog by pressing Cancel.

See Also

The Recording Dialog



Speeding Up or Slowing Down a Sound
You can change the speed at which the sound is played back. The speed is specified in 
samples per second, or hertz (Hz). The default speed is 22,050 Hz, or approximately 22 
kilohertz (kHz). Windows can handle any speed between 4000 and 44,100 Hz.

To change the playback speed of the current sound

1 From the Effects menu, select Playback Rate.
2 Enter the new speed in hertz, or select a standard speed from the drop-down list. To 

enter a rate in kilohertz, suffix it with the letter 'K'.
3 Click on OK, or press ENTER.

See Also
Playback Rate Dialog



Editing Information about a Sound
Sounds stored in the RIFF Waveform and IFF formats can contain information about their 
contents. You can inspect this information, modify it or enter your own information.

To view or edit the current sound's information

1 From the File menu, select Information.
You will be presented with a dialog containing any information present in the current 

sound. Here you can enter your own information.

See Also
File Information Dialog



Selecting Part of a Sound
You can select part of the current sound. Then you can play the selection, copy it to the 
Clipboard or modify it.
If you are not satisfied with how much you have selected, you can move the start and end of
the selection.

To select part of the current sound
1 Position the mouse cursor over the start of the part of the waveform that you wish to 

select.
2 Hold down the left mouse button and drag to the end of the part that you wish to select.
3 Release the left mouse button.

The selected part of the sound is displayed inversed.

To change how much is selected

1 Position the mouse cursor over the marker beneath the start or end of the selected area.
2 Hold down the left mouse button and drag the marker to its new position.
3 Release the left mouse button.

Hint: To see whether you have selected the right part of the sound, press and hold down 
Ctrl and press P, or click on the 'Play selection' button.  



Changing the Volume of Part of a Sound
You can increase or decrease the volume of the current sound, or of any part of it.

To double the volume of part of a sound

1 Select the part of the sound whose volume you wish to double. This is not necessary if 
you wish to double the volume of the entire sound.

2 From the Effects menu, select Volume, and then select Increase (200%) from the menu 
that pops up.

Note: If part of a sound is already very loud, increasing its volume will distort it.

To halve the volume of part of a sound

1 Select the part of the sound whose volume you wish to halve. This is not necessary if 
you wish to halve the volume of the entire sound.

2 From the Effects menu, select Volume, and then select Decrease (50%) from the 
menu that pops up.

To change the volume of part of a sound by a percentage

1 Select the part of the sound whose volume you wish to change. This is not necessary if 
you wish to change the volume of the entire sound.

2 From the Effects menu, select Volume, and then select Change... from the menu that 
pops up.

3 Enter the percentage that you wish to change the volume by and click on OK or press 
Enter.
For example, 300% will treble the volume and 50% will halve it.

Note: If part of a sound is already very loud, increasing its volume will distort it.



Clearing Part of a Sound
You can clear part of a sound. This erases that part of the sound, replacing it with silence.

To clear part of a sound

1 Select the part of the sound that you wish to clear.
2 From the Effects menu, select Clear.



Reversing Part of a Sound
You can reverse the order of part of a sound. This causes that part to be played backwards.

To reverse part of a sound
1 Select the part that you wish to reverse. If you wish to reverse the entire sound, do not 

select anything.
2 From the Effects menu, select Reverse.



Converting Amiga Sounds
You can convert signed sounds, such as Amiga sounds, to the unsigned format used by 
Windows. You can also convert sounds to signed format.

To convert the current sound from signed to unsigned format (or vice versa)

From the Effects menu, select Change sign.



Saving Part of a Sound to Disk
You can select part of a sound and save it to disk as a separate sound.

To save part of the current sound to disk
1 Select the part of the sound that you wish to save.
2 From the Edit menu, select Copy to file.
3 Enter the name for the new file in the dialog. You can also select the format (and in 
some cases the encoding)to save the sound in.



Deleting Part of a Sound
You can delete part of a sound. That part is removed and the sound becomes shorter.

To delete part of the current sound
1 Select the part of the sound that you wish to delete.
2 From the Edit menu, select Delete.

To delete all but part of the current sound
1 Select the part of the sound that you wish to keep.
2 From the Edit menu, select Delete unselected.



Inserting Sound from the Clipboard
You can append sound that is on the clipboard to the end of the current sound, or insert it 
into the current sound at any point. You can also replace the current sound, if any, with 
sound from the clipboard.

To insert sound from the clipboard at the start of the current sound
1 From the Edit menu, select Paste.

or click on the Paste button.
2 In the dialog that appears, select the Insert at start option button and click on OK.

To append sound from the clipboard to the end of the current sound
1 From the Edit menu, select Paste.

or click on the Paste button.
2 In the dialog that appears, select the Add to end option button and click on OK.

To insert sound from the clipboard into the current sound
1 Select the part of the sound that you wish to replace with the sound in the clipboard.
2 From the Edit menu, select Paste.

or click on the Paste button.
3 In the dialog that appears, select the Replace selection option button and click on OK.

To replace the current sound with the contents of the clipboard
1 From the Edit menu, select Paste.

or click on the Paste button.
2 In the dialog that appears, select the Replace waveform option button and click on 

OK.



Copying Sound to the Clipboard
You can copy the current sound, or part of it, to the Clipboard. From there, it can be inserted 
into sounds in WHAM.

To copy part of a sound to the clipboard
1 Select the part of the current sound that you wish to copy. If you wish to copy the entire 

sound, do not select anything.
2 From the Edit menu, select Copy.

or click on the Copy button.

To copy part of a sound to the clipboard and delete it
1 Select the part of the current sound that you wish to copy. If you wish to copy the entire 

sound, do not select anything.
2 From the Edit menu, select Cut.

or click on the Cut button.

See Also
Inserting Sound from the Clipboard



Saving a Sound to Disk
You can save the current sound to a file on disk. This file can be in one of several formats 
supported by WHAM.

To save the current sound to disk
1 From the File menu, select Save.

or click on the Save button.
2 If the sound has not been given a name, WHAM will prompt you to enter a name for it. 

You can also select the format in which it is saved and, in some cases, the encoding.

To save the current sound under a different name or in a different format
1 From the File menu, select Save As.
2 WHAM will prompt you for a name for the sound. You can also select the format and, in 

some cases, the encoding in which it is saved.



Loading a Sound from Disk
You can load an existing sound file, such as one of the sounds provided with Windows, into 
WHAM.

To load a sound file from disk
1 From the File menu, select Open.

or click on the Open button.
2 Select the file name from the list. You can change directories and drives through the 

dialog. You can also select the type of files that you wish to load.



Playing a Sound
You can play the current sound, or a part of it, through your sound output device.

To play the current sound
Press 'P',

 or click on the 'Play' button.

To play part of the current sound
Press and hold down Ctrl and press P,

 or click on the 'Play selection' button.



File Information Dialog
The File Information dialog contains a number of fields that may contain information about 
the current sound. This information may be stored in sound files.

Title

This field contains the title of the current sound. You can give your sounds titles. This field 
can be stored in RIFF Waveform and IFF files.

Creation date

This shows the date of creation for the current sound. This can be stored in RIFF Waveform 
files. If no date is stored in the current file, or it is not a RIFF Waveform file, WHAM can fill 
this field from the DOS creation date of the file.

Software

This shows the software used to create or edit the current sound. This field exists in RIFF 
Waveform and IFF files.

RIFF Info >>

Pressing this button expands the information dialog, revealing additional controls which 
allow you to edit other types of information. These are;

Item

This is a list of items of information (such as artist name, comments, genre, etc.) which may 
be edited; all of these can be stored in a RIFF waveform file; some may also be stored in files
of other formats. Any item which contains information will have a tick against its name.

Description

This box contains a description of the purpose and suggested usage of the currently selected
information item.

Value

This field contains the information assigned to a particular item. You may edit the 
information in this field.



Information Defaults Dialog
This dialog allows you to set options relating to the storage of user-defined information in 
sound files.

Get creation date from DOS

If this is checked, WHAM will fill the Creation Date information field from a file's DOS creation
date if no date is stored in the file. If this is unchecked, this field is left blank and filled with 
the current date when the file is saved.



    Window Options Dialog
This dialog allows you to customise the behaviour of the WHAM window.

Vertical Sizing Mode

This specifies what, if any, vertical resizing is allowed. The options are;

No vertical resizing The window may be resized horizontally, but not vertically.
Snap to scale The window may be resized both horizontally and vertically. Upon 

resizing, it will shrink to the smallest size required to display sounds at
the vertical scale to which it has been resized.

Full resizing The window may be resized both horizontally and vertically.



Playback Rate Dialog
This dialog prompts you for the rate at which the sound is to be played back. Enter the rate 
in hertz, or alternatively, in kilohertz suffixed with the letter K.
Thus, "22000" and "22K" are equivalent.



The Recording Dialog
This dialog is used to record sound. It contains several buttons, which are:

Record

This button starts the recording process (actually, you may have to wait a few seconds while
WHAM gropes around for available memory before recording starts.)    

Stop

This button causes recording or playback to be stopped.

Play

This button plays back the sound that has been recorded.

OK

This button closes the recording dialog. If a sound has been recorded, it becomes the current
sound and is displayed in the WHAM main window.

Cancel

This button closes the recording dialog, discarding any sound that has been recorded.

Options>>

This button extends the dialog, revealing additional controls which may be used to configure
how sound is recorded. These are:

Sample rate

This combo box may be used to select at what sample rate sound is recorded. The values it 
contains depend on the capabilities of your hardware.

Resolution

This combo box may be used to select at what resolution sound is recorded. The values it 
contains depend on the capabilities of your hardware.

See Also

    Recording a Sound



The Format Defaults Dialog
This dialog allows you to configure the behaviour of WHAM's file format drivers. It contains a 
list of drivers which have configurable options. To set the options for a file format, select the 
format name in the list and press the Options button.

Currently, the following file formats shipped with WHAM allow options to be configured:

RIFF Waveform

The RIFF waveform allows you to select whether information is written with the file. You may 
wish to disable this information to allow badly behaved applications to read .WAV files 
written with WHAM.

Amiga IFF (8SVX) sound

The IFF driver contains a sophisticated information mapping mechanism; this allows you to 
choose which items of information are written to an IFF file and to what standard IFF 
information chunks they are mapped.

See Also
    Sound file formats



The System Information Dialog
This dialog contains information about your hardware and your system.

The system information dialog contains two areas; one area contains information about your 
sound input device and the other about your sound output device. If either device is not 
present, the relevant area will be greyed.

These areas contain the following fields:

Device name

This field contains the name of the device, as defined in the device driver.

Number of channels

This is the number of channels of simultaneous input or output that the device can handle at
once. WHAM only ever uses one channel.

Maximum sample/playback rate

This is the maximum rate at which sound can be recorded or played back through the 
device.

Maximum resolution

This is the maximum resolution that the device can handle.

At the bottom of the dialog is a field labelled "free memory". It displays some ridiculously 
high figure, because Windows insists on counting available virtual memory. (The only way to 
determine how much RAM is actually available is to physically attempt to allocate blocks of 
various sizes, which is what the sound recording routine does.)



The Display Options Dialog
This dialog allows you to configure the way in which WHAM presents the current sound on 
the screen.

(Mark ruler in) bytes

If this radio button is checked, the ruler at the bottom of the WHAM window will be marked 
in bytes from the start of the sound.

(Mark ruler in) seconds

If this radio button is checked, the ruler will be marked in seconds from the start of the 
sound.

(Ruler scale) Automatic

If this radio button is checked, WHAM will automatically determine the scale of the ruler and 
the grid.

(Ruler scale) User-defined

If this radio button is checked, the ruler scale will be a multiple of the number in the edit 
field to the right of this button.

(Grid) Vertical frequency

This combo box allows you to select into how many sections the waveform is divided 
vertically. If you select 1, there will be no vertical grid.

Grid color

This button is filled with the colour currently used to draw the grid. If you press it, a dialog 
will appear allowing you to change the colour.

Draw horizontal grid

If this checkbox is checked, WHAM imposes a horizontal grid on the waveform. This 
horizontal grid is drawn at (and between) ruler increments.



The Status Line

The status line is the area at the bottom of the WHAM window. When a sound is loaded, it 
will display information in several compartments, as follows:

1] Size of sound. This is the physical size of the current sound in bytes.
2] Length of sound. This is the length of the current sound in seconds.
3] Sample rate. This is the rate at which the current sound is played back, in kilohertz.
4] Resolution. This is the resolution of the current sound, in bits per sample.
5] Viewing scale. This is the scale at which the current sound is shown.
6] Modified flag. If the current sound has been modified since it was last written to disk, 

the word "Modified" will be displayed here.
7] Selection/cursor position. If part of the current sound is selected, this will contain 

information about how much is selected and whence; otherwise it will contain the 
position of the cursor, as an offset from the start of the sound.

Finally, the rightmost portion of the status line will contain information about any operation 
in progress, such as "Playing"; normally it will be blank.



The Button Bar

The button bar is near the top of the WHAM window. It contains buttons that cause certain 
functions to be performed when they are pressed. In addition, some buttons will show a 
menu of other buttons when clicked with the right mouse button.

Play

This button causes the current sound to be played in its entirety.

Play from cursor

This button causes the current sound to be played from the position of the cursor to the end.
It is only present when nothing is selected.

Play selection

This button causes the selected portion of the current sound to be played. It is only present 
if part of the sound is selected.

Stop

This button causes playback to stop. It is enabled only if a sound is currently being played.

Record

This button invokes the recording dialog, allowing you to record a sound through your sound 
card.

Open

This button brings up a dialog prompting you to select a sound to load into memory.

Save

This button causes the current sound to be saved to disk.

Save As



This button is displayed when the Save button is pressed with the right mouse 
button. This button brings up a dialog, prompting you for a new name to save the 
current sound under.

Cut

This button causes the current selection to be copied to the clipboard and removed.

Copy

This button causes the current selection to be copied to the clipboard.

Paste

This button causes the contents of the clipboard to be inserted into the current sound. If it is 
pressed with the left mouse button, a dialog is displayed, prompting you for the method of 
insertion. If pressed with the right mouse button, three buttons appear.

Paste at cursor/selection

If this button is pressed, the contents of the clipboard will replace the currently 
selected portion of the current sound, if any part is selected, or else they will be 
inserted at the cursor position.

Paste at start

If this button is pressed, the contents of the clipboard will be inserted at the start of 
the current sound.

Paste at end

If this button is pressed, the contents of the clipboard will be appended at the end of 
the current sound.

Delete

This button causes the current selection to be removed.

Zoom in

If this button is pressed, WHAM will zoom in on the current selection.



Zoom out

If this button is pressed, the entire sound will be displayed.

Actual size

If this button is pressed, the current sound will be displayed at actual size.

Information

If this button is pressed, you will be prompted with a dialog allowing you to see and change 
information about the current sound.

System information

This button invokes the system information dialog which displays information about 
your hardware.



Questions
Q: Can WHAM record sound?
A: Yes. Since the last version, I have acquired a sound card and have put in a sound 
recording option.
Q: Can I transfer sound between WHAM and Sound Recorder?
A: You can transfer sound from the Sound Recorder to WHAM, but not the other way. The 
Sound Recorder is an OLE application, and was not intended to transfer data by other 
means. Of course, you can save a sound in WHAM and open it in the Sound Recorder.
Q: What do I do if a sound sounds noisy and distorted?
A: If the sound sounds dirty and the waveform looks messy that the sound is probably in 
signed format (as used on the Amiga). Before playing it, convert it to unsigned format by 
selecting the Effects|Change Sign function.
If the sound sounds slightly distorted and the waveform display shows many curved 
(parabolic or hyperbolic) patterns, then the sound is probably in Mu-Law format. You can 
convert this to linear format by selecting Effects|Decode Mu-Law data.
Q: <Insert name of program> cannot read .WAV files created by WHAM. Is this a 
bug in WHAM?
A: No, WHAM implements the RIFF format as defined in the official Microsoft/IBM 
specification; it, however, is a bug in the other program. Some programs cannot handle RIFF 
waveform files containing anything but the sound and its header. If you wish WHAM to write 
RIFF files without additional information, select "Format defaults" from the Options menu, 
select the RIFF Waveform format and change its options to omit the INFO chunk from RIFF 
waveform files.
Q: Can WHAM handle Macintosh sound formats?
A: Unfortunately not. I would have liked to have put in SND resource read and write 
capabilities, but I can't find the Macintosh sound resource format. I have only seen programs
that write this format on the Macintosh, and I have heard that these use some system 
functions.

If you wish to convert your favourite Windows sounds to Macintosh files, you must firstly 
save them to an intermediate format and use a Macintosh utility to do the conversion. To do 
this, I save files in IFF format and use a Macintosh program called AmigaSndConvert to 
convert them to Macintosh sound files.



Signed and Unsigned Samples
There are two ways of storing digitised sound; with signed samples and unsigned samples. 
Signed samples are values ranging from -128 to 127 and centred around 0. Unsigned 
samples are centred around 128 and range from 0 to 255. Windows uses unsigned samples.



Sample
Digitised sound consists of a series of samples. A sample is an individual reading of volume. 



Marker  
A marker is a small triangle, immediately below the waveform display, representing the start
or end of a selection. By dragging a marker, you can change the selection.



Sound File Formats
Note: These are only the file formats which are shipped with WHAM. Other formats may 
become available separately.
RIFF Waveform The Microsoft Windows 'WAVE' sound format. This format is used for 

Windows system sounds. RIFF Waveform files have the extension '.WAV'. 
RIFF Waveform sounds may be of    either 8-bit or 16-bit resolution.

Raw 8-bit sample Sound files in this format consist of nothing more than the samples 
that they are comprised of.

Creative Voice This is the SoundBlaster sound format and has the extension, '.VOC'. 
WHAM can currently only deal with uncompressed .VOC files. The WHAM 
VOC format driver can only handle 8-bit VOC files.

Amiga IFF This is the standard Amiga 8-bit sound (8SVX) format. These files are often
given the extension, '.IFF'. These files can contain eight-bit sounds only.

Sun/NeXT sound This is the standard sound format of the Sun and NeXT workstations, 
and traditionally have the extension, '.au'. These formats can contain 
either 8-bit or 16-bit linear or mu-law samples. 

AIFF This format was developed by Apple and is also used by Silicon Graphics 
(SGI) workstations. The AIFF file structure is based on the Amiga IFF 
tagged file structure, although it is not the same as the IFF (8SVX) format. 
AIFF files may be of 8-bit or 16-bit resolution.



Linear and Mu-law samples
Most sounds are stored using linear samples. Here, the amplitude readings are conventional,
linear numbers.
Mu-law samples are another way of encoding sounds. In mu-law-encoded sounds, samples 
are logarithmic, rather than linear. This has the advantage of giving 14-bit resolution, while 
only taking up eight bits of space. Mu-law encoding is used mainly on workstations.
Most sound drivers for Microsoft Windows 3.1 do not directly support mu-law encoding, 
which is a shame. This means that sounds currently have to be converted to linear samples 
in order to be played from Windows.    However, Microsoft have released an updated RIFF 
sound file specification, which includes support for mu-law encoding. I will add full mu-law 
support to WHAM as soon as I have a Windows sound driver (for the Gravis UltraSound) that 
complies with the updated specification.



Information
User-defined information may be stored in RIFF Waveform and IFF sound files. This 
information included things such as the sound title, artist name and a copyright message.



Cursor
The cursor is a flashing vertical bar that denotes a position in the sound. You can insert 
sounds from the clipboard at the cursor and play the portion of the current sound starting at 
the cursor.



Resolution
The resolution of a sound is the size of its samples, in bits. At present., WHAM can handle 
two resolutions; 8 and 16 bit.



Encoding
The term "encoding" refers to the way in which a sound is written to a file. Some file formats
support several different encodings; for example, 16-bit sounds may be stored in Sun/NeXT 
audio files in either 16-bit linear or Mu-Law encoding.



File format drivers
WHAM 1.3 uses external dynamic-link libraries (DLLs) to read and write sound files. Each 
format supported by WHAM has one such library, called a file format driver. The use of 
these drivers makes it possible to add file formats without modifying the WHAM executable.


